Go Back   Rotary Car Club > Tech Discussion > Interior, Stereo, Body kits, etc...

Interior, Stereo, Body kits, etc... Place where you could talk about car care, body kits, painting your car, Carbon Fiber, Thumping Stereo, etc..

Reply
 
Thread Tools Display Modes
Old 04-29-2015, 01:31 PM   #1
RETed
RCC Addict
 
Join Date: Mar 2008
Location: Honolulu, Hawaii USA
iTrader: (1)
Posts: 1,793
Rep Power: 11
RETed will become famous soon enough
Default Tekniq STREET Snap-Off System binding lock

Dropped in here for reference...

http://www.tekniqauto.com/US/steeringquickrelease.htm

Tekniq has already stopped producing these things, as they have only kept the RACE version of this system which does NOT include the lock.

If you owned one of the older STREET systems which has the tubular lock, you may run into binding problems with the lock itself.
I own one of the last ones that were produced, and I've owned it about 2 - 3 years now.
Recently, I found that the lock tumbler was binding when I needed to unlock the unit to remove.
I thought the lock needed to be replaced, but it turned out to be an easy fix...

The lock tumbler itself is held with a single spring pin - easy to remove and install.
There is only one spring pin, and it's the larger of the obvious pins on the outside of the cylinder.
The really tiny pins are roll pins that keep the assembly together - don't touch them!
The larger spring pin is easy to depress and remove the lock cylinder.
Once that's out, lube the single, small spring and the locking latch from the inside - I find this is cleaner, since grease should stay inside the lock cylinder rather than greasing it from the outside with the chance the grease and leak out onto everything.
You don't need to go overboard; just coat the parts with a light coating of your favorite grease.

I didn't realize until after doing this, but the lock latch actually rotates when you turn the lock tumbler.
I always assumed the lock latch just retracted in, but it's this turning motion that was causing the binding.

Once everything is lubed, the lock turned like butter!
Even the *click* sound when the lock engaged when putting the steering wheel on disappeared - not necessarily a positive thing, since that was what told me the steering wheel was positively engaged.
The lock system did not work this smooth even when it was brand new, so I doubt the lock was ever lubed from the factory...

Whatever the case, problem solved!


-Ted
__________________
reted_2000@yahoo.com
Technical Advisor
FC3S Pro
http://fc3spro.com/



Quote:
Originally Posted by TitaniumTT View Post
because you're only as good as your backup
RETed is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:56 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Hosted by www.GotPlacement.com
Ad Management by RedTyger