Go Back   Rotary Car Club > Tech Discussion > RX-8 (2004 - Present)

RX-8 (2004 - Present) All things to do with RX-8

Reply
 
Thread Tools Display Modes
Old 11-26-2015, 01:04 AM   #1
trigby14
The Newbie
 
Join Date: Oct 2015
Location: Parma Hts. Ohio
iTrader: (0)
Posts: 4
Rep Power: 0
trigby14 is on a distinguished road
Default Idling problem

I have a 2004 rx8 6speed MT that is idling different than before. Doesn't matter if the car is cold or has been warmed up it acts the same.(when its cold it bounces at higher rpms but the rest is the same) So whats happening when its warm is when I have the clutch pushed to the floor it idles normal at 800-900rpms and is steady. But when I let the clutch out all the way in neutral it jumps to 1500rpms for a second and then drops to 800 then jumps back up every few seconds and just keeps bouncing. Goes back to normal when I push the clutch in. Have not noticed anything else while driving the car but for now it will sit until I figure this out. Any suggestions on what to check for or what could be causing it would be helpful.






trigby14 is offline   Reply With Quote
Old 11-26-2015, 07:42 AM   #2
JL1RX7
Rotary Fanatic
 
Join Date: Feb 2008
Location: Front Royal, VA
iTrader: (1)
Posts: 485
Rep Power: 10
JL1RX7 will become famous soon enough
Default

Usually most issues with 8's can be traced to a few things. One how old are the plugs and wires? Over 20k replace them and see what it does. Second clean the MAF sensor. Third make sure your battery connections are good. After you have done all of this, and it's still doing it then more serious troubleshooting will be required.
JL1RX7 is offline   Reply With Quote
Old 11-26-2015, 08:05 AM   #3
trigby14
The Newbie
 
Join Date: Oct 2015
Location: Parma Hts. Ohio
iTrader: (0)
Posts: 4
Rep Power: 0
trigby14 is on a distinguished road
Default

I am not sure how old the plugs and wires are but from what the person said that I bought it from they are probably getting to around the 20k mark. I will clean the sensor and hope that one of those fixes it. Thank you for your advice.
trigby14 is offline   Reply With Quote
Reply

Bookmarks

Tags
idle, rx8

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 01:11 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Hosted by www.GotPlacement.com
Ad Management by RedTyger